Question: Why are multiple DLL files failing to register when installing Dragon Naturally Speaking?
Problem:
At the end of the installation process, an error message appears that states:The following files were not registered successfully:”, and multiple DLL files may be listed.
Cause:
This error message is caused by an incomplete installation of Dragon NaturallySpeaking, or theregsvr32.exe” file is not in the correct location on the computer. Theregsvr32.exe” file is used to register and unregister DLL files, and this file needs to be accessed by Dragon NaturallySpeaking when the installation is complete.
Solution # 1:
Run a repair on Dragon NaturallySpeaking:

  1. ClickStart > Control Panel”.
  2. ClickAdd or Remove Programs” in Windows XP, orPrograms and Features” in Windows Vista.
  3. Click on the Dragon NaturallySpeaking 9 (or the Dragon NaturallySpeaking 10) installation, then click theChange” button.
  4. Once the Dragon NaturallySpeaking installation dialog appears, click theNext” button.
  5. Select theRepair” option and then clickNext”.
  6. Click on theInstall” button and let the installation complete.
  7. If the same error message appears after repairing Dragon NaturallySpeaking, please follow Solution # 2 listed below.

Solution # 2:
Ensure that theregsvr32.exe” file is in the correct location. The correct location for theregsvr32.exe” file is in theC:Windowssystem32″ folder. Use Windows Explorer to search for this file in theC:Windowssystem32″ folder. If this file is not found in theC:Windowssystem32″ directory, please search the computer for this file and copy it to theC:Windowssystem32″ folder using the steps below.
To search the computer for theregsvr32.exe” file on Windows XP:

  1. ClickStart > Search”.
  2. Click onAll files and folders” when prompted to selectWhat do you want to search for?”.
  3. Typeregsvr32.exe” in theAll of part of the file name:” field.
  4. SelectLocal Hard Drives” for theLook in:” field.
  5. Click theMore advanced options” button and select theSearch hidden files and folders” checkbox.
  6. Click theSearch” button to start searching for the file.
  7. Once the search results have been returned, verify if the file is located in theC:Windowssystem32″ directory.

To search the computer for theregsvr32.exe” file on Windows Vista:

  1. ClickStart > Search”.
  2. Click on theAdvanced Search” button to drop down additional search criteria.
  3. Change theLocation” setting toLocal Hard Drives”.
  4. Check theInclude non-indexed, hidden, and system files” checkbox.
  5. Typeregsvr32.exe” in theName” field.
  6. Click theSearch” button to start searching for the file.
  7. Once the search results have been returned, verify if the file is located in theC:Windowssystem32″ directory.

After searching for theregsvr32.exe” file:

  • If theregsvr32.exe” file is not located in the proper folder, make a copy of the newest version of theregsvr32.exe” file and paste it into theC:Windowssystem32″ directory. For instructions on how to verify the file version, see the steps below.
  • If the file is located in the proper folder, verify that the version of theregsvr32.exe” file is equal to or greater than the versions that are listed below.

To check the version of theregsvr32.exe” file:

  1. Right click on theregsvr32.exe” file and selectProperties”.
  2. Click on theVersion” tab on Windows XP, or theDetails” tab on Windows Vista.
  3. Find the field that saysFile Version:” and verify that the version is equal to or greater than the file versions listed below:
    • The most recent version ofregsvr32.exe” for Windows XP is version 5.1.2600.2180, as of June 5th, 2007.
    • The most recent version ofregsvr32.exe” for Windows Vista is 6.0.6000.16386, as of June 5th, 2007.

Note: If theregsvr32.exe” version is less than the versions listed above, contact Microsoft or the computer manufacturer for the newest version of theregsvr32.exe” file.
Verification source: Nuance Knowledge base. TechNote Number: 5862